Skip to toolbar

A Question In Video Form

Home Forums General Compressors, tanks and pumps A Question In Video Form

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #19516
    airgun-bill
    Participant

    I had trouble today in filling my Talon with the scuba tank clamp. I hope it is a simple fix and the video shows what I think is the problem.

    #230299
    powderburner
    Participant

    mines like this
    http://www.airforceairguns.com/AirForce-Airguns-K-Valve-Fill-System-p/u1012.htm

    the bleed valve ,knob/ screw,is neoprene or such and seals against the alloy housing, no oring or seal.

    #230331
    maw
    Participant

    go to Ace, I suspect it has a loose fitting o-ring, in order for it to come off.

    #230360
    airgun-bill
    Participant

    I will try finding an o-ring to see if it helps. I found at home later I had another k valve with a QR male foster and a hose assembly set up for an older hand pump to work. I had my Hill pump with me and used it to fill the tank. I know it took more than 125 pumps to get the tank up to 2700psi. I had hernia surgery back in March and felt the effect of pump use afterwards. Part of what I was doing yesterday was trying to find the optimum fill rate for my tank. I’m getting around 30 shots per tank fill with JSB Exact Heavy velocity range from 800fps down to 760 fps before fall off. I also shot at some homemade field target I had made years ago. It was a fun day other than the pumping. Airgun Bill
    Here are my homemade steel targets


Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.